канал по ремонту на ютуб

Ремонт ноутбука своими руками.

Объявление

Уважаемые пользователи ! "Контакты наших мастеров" - в шапке форума, либо снизу, в разделе : "Закреплено" .

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Ремонт ноутбука своими руками. » Asus, Toshiba » Toshiba L350-156 shuts down after 2 seconds display.


Toshiba L350-156 shuts down after 2 seconds display.

Сообщений 1 страница 21 из 21

1

Hi,

Toshiba L350-156  displays 1 to 2 seconds and shuts down.
Platform : 6050A2170201-mb-A03

All voltages and signals are ok.

As I alreday fixed 3 toshiba L350 with Nec Tokin problem, replaced Nec Tokin C79 with 4 caps of 330u each, as well as C641 220u located under the CPU (+VCCP) with no avail.

Any suggestion as where to dig further should be of a great help!

Thank you

0

2

Привет ( HI  8-)  ).

Platform : 6050A2170201-mb-A03 - this I understand PT10SC ?

Try to turn the laptop from a laboratory power supply with setting the supply voltage is 21 volts and a current of 4.7 amps

Remove the cmos battery , short-circuit kontakty , try to boot without the cmos battery , and then together with her.

Check the resistance and voltage lines EC_DATA and EC_CLK.

Try to replace the Thermal Sensor  G784

0

3

freeqwer написал(а):

Hello (HI     ).

Platform: 6050A2170201-MB-A03 - I Understand this PT10SC ?


Inventec PT10SC

freeqwer написал(а):

Try to turn the laptop from a laboratory power supply with setting the supply voltage is 21 volts and a current of 4.7 amps
Remove the cmos battery , short-circuit kontakty , try to boot without the cmos battery , and then together with her.


Tried lap as suggested above. Didn't help.

freeqwer написал(а):

Check the resistance and Voltage Lines EC_DATA and EC_CLK


High resistance value : over 10k
Voltage : +3.78V; +3.79V

Try to replace the Thermal Sensor  G784

Voltages at G784 pins :
1. +3.8V        5. GND         
2. +0.4V        6. nc
3. 0V             7. +3.79V
4. 3.8V          8. +3.78V

voltages seem to be ok
Tested G784 by pulling down THRM_SHUTDWN# to gnd, lap shuts immediately.

Add :
Lap when switched on with DC only, led sequence is the following:
PWR_BLED#(D38) on/off, then PWR_OLED#(D37) flashes 2 Times orange then off;
The same sequence is repeated a 2nd time;
Then PWR_BLED# on and lap shuts down, remains only DCIN_BLED #

Where to dig further ?

Thank you

.

0

4

Bios -redamp ?
Separately from the battery work ?
The battery is charging ?
Tested whether replacing with a known good components : cpu , ddr ?
Try to turn on the laptop with one module DDR separately in each slot .
What is the level of signal EC_PW_ON if you unplug the laptop ?
What is the level of signal +V3LA  +V3LDO  +V5LA   if you unplug the laptop ?

0

5

freeqwer написал(а):

Bios -redamp?


yes bios re-dumped with 2 valid dumps, no result.

freeqwer написал(а):

Separately from the battery work?
The battery is charging?


Laptop brought by customer without battery.

freeqwer написал(а):

Tested Whether Replacing with A Known good components: cpu, ddr?
Try to Turn on the One Laptop with DDR module separately in each Slot.


All already done as 1st steps !

freeqwer написал(а):

What is the Level of signal EC_PW_ON if you unplug the Laptop?
What is the Level of signal V3LA + + + V3LDO V5LA    if you unplug the Laptop??


Voltages measured with DC plugged in and laptop off :
EC_PW_ON : +3.78V
V3LA : +3.79v  V5LA :+ 5.73v
V3LDO : +3.78v

0

6

+VCC_CORE manages to climb at the start ?

0

7

freeqwer написал(а):

+ VCC_CORE manages to climb at the start?


As soon as lap is swiched on, VCC_CORE starts at +0.96V (sometimes +0.85V)  rises to +1.1V stabilizes at +1.1V then up to +1.3V and immediately shut down occurs.

0

8

:dontknow:
check Q518,   Q517,   Q519,   Q520,  D11,  D24, R579, R578, R333, C298, R338, R177

0

9

freeqwer написал(а):

check Q518,   Q517,   Q519,   Q520,  D11,  D24, R579, R578, R333, C298, R338, R177


Hi!
Q517, Q518, Q519, Q520, D11, D24, R578, R579, R338, R177 are all tested ok.

R333 doesn't exist. On the scheme it's marked as open.

But your suggestion to check the above components, is likely to put me on the right track!
I discover that :
VSSSENCE Resistance to Gnd is : 100R without CPU (that's normal) but =0R when any [b]good CPU is inserted, that's abnormal !![/b] isn'it ?
Also VCCSENCE Resistance to GND is : 1.1K without CPU but only 14R when CPU is inserted!

May I conclude with no doubt that ADP3208 is partially failing and need replacement ?

Please advice !

Thank yo :unsure: u

0

10

mohkamtun написал(а):

VSSSENCE Resistance to Gnd is : 100R without CPU (that's normal) but =0R when any good CPU is inserted, that's abnormal !! isn'it ?


This is normal.

VSSSENCE is grounding processor . It is through this contact (output) PWM determines that the processor has a normal contact with the case (a common ground wire) .

You can try to set the values VID0-VID6 manually at a certain value and to compare the received voltage with a voltage in the Datasheet .

Still try to disable one of the phases . And run the laptop on each phase separately.

0

11

Hi!
Oh, I just realized that you reply to my last post.

freeqwer написал(а):

Still try to disable one of the phases . And run the laptop on each phase separately.

Will try tomorrow and give feed back.

freeqwer написал(а):

You can try to set the values VID0-VID6 manually at a certain value and to compare the received voltage with a voltage in the Datasheet .


Do you mean by setting VID0-VID6 values manually that I ground for instance 1 or 2 of VID pins, and compare VRM ouput with CPU VID TABLE ?

Add, Tosh L350 tested with Debug card 5 in 1, I just bought, so I'm not yet quite familiar with,
Test shows : AF-94- then stops at code 78. Does this code error pinpoint any failure ?

Thank you

Отредактировано mohkamtun (15.03.2015 02:19:41)

0

12

mohkamtun написал(а):

and to compare the received voltage with a voltage in the Datasheet

yas

mohkamtun написал(а):

AF-94- then stops at code 78


Who is the manufacturer of the BIOS ?

Read here :
link
link
link


Recommend
, install, post-map in different working laptops and record post-codes, or create a video pass codes.
Doing it for further analysis in the repair.
So in the future will be easier.

Download here (working BIOS and service manual for the Toshiba) :
LINK

0

13

freeqwer написал(а):

You can try to set the values VID0-VID6 manually at a certain value and to compare the received voltage with a voltage in the Datasheet .


As said in my previous posts VCC_core initially measured : 0.96V (in VID table 0.95V, so almost the same)

But When I grounded VID2, VID3 and VID4 (CPU not in socket), I found VCC_CORE=0V, though VID0-VID6 are 1100011, so it should be 1.54V according to VID table ???

freeqwer написал(а):

Still try to disable one of the phases . And run the laptop on each phase separately.


Disabled one phase at a time, got always VCC_CORE=0V  ??? though VID0-VID6 measured : 0011100

freeqwer написал(а):

Who is the manufacturer of the BIOS ?


How to find out the BIOS manufacturer of the Toshiba L350, as lap displays only 1 to 2 sec and then off ?
Also, In Schema and Manual I dont see any indication!

freeqwer написал(а):

Read here :
link
link
link


Thank you for the bios codes links, I knew only bios central, the 2 other links are very useful.

freeqwer написал(а):

Recommend , install, post-map in different working laptops and record post-codes, or create a video pass codes.
Doing it for further analysis in the repair.
So in the future will be easier.


I got the idea of making my own database for post-codes of working laps, but creating video pass codes this is very interesting so thank you for the recommendation.

0

14

mohkamtun написал(а):

But When I grounded VID2, VID3 and VID4 (CPU not in socket), I found VCC_CORE=0V, though VID0-VID6 are 1100011, so it should be 1.54V according to VID table ???


1100011 - corresponds to the value  0.2625 V

I'm not sure you can check this PWM without a processor.
You need to carefully read the Datasheet.

It should be made conditions :

- VCCDRE_EN
- H_VID [ 0 : 6 ]
- IMVP_CKEN#
- PM_DPRSLPVR

Try to set socket processor to perform the disconnection of one phase.

If there is, it's faster to install a known working PWM.
If not available , then ordered . If anything , it will be useful for the future.

What is the status signals :

- VCORE_EN
- VR_PWRGD
- IMVP_CKEN#
- TTSEN (TTSNS )

When the shutdown of the laptop disappears, only the voltage on the CPU ?
What are the voltages on the Board are still working ?

0

15

freeqwer написал(а):

1100011 - corresponds to the value  0.2625 V


Y're right it's 0.2625V, I got confused. (Already, 1.54V doesn't exist in VID table max +1.5V)

freeqwer написал(а):

I'm not sure you can check this PWM without a processor.
You need to carefully read the Datasheet.

It should be made conditions :

- VCCDRE_EN
- H_VID [0: 6]
- IMVP_CKEN #
- PM_DPRSLPVR


Yes,  it seems that processor is needed for checking PWM.
Today, I shorted VID1 and VID2 to gnd and got VCC_core +1.12V (should be +1.0V according to VID table 
0101000). +10%volts, I think it's within tolerance, isn't it ?

freeqwer написал(а):

Try to set socket processor to perform the disconnection of one phase.


I disconnected both L510 and L513, of course one at a time, and got always VCC_CORE : +0V ?? Processor with only one phase is not working! strange isn't ?

How can we set socket processor to perform disconnection of one phase differently?
Does, Pulling pin SP high (supply of +2V directly to pin 38) help or is there another way to do?

freeqwer написал(а):

If there is, it's faster to install a known working PWM.
If not available , then ordered . If anything , it will be useful for the future.


Will try to find out ADP3208 IC on our market and will add it to my pending IC order.

freeqwer написал(а):

What is the status signals :

- VCORE_EN
- VR_PWRGD
- IMVP_CKEN #
- TTSEN (TTSNS)


-VCORE_EN : +3.78V
-VR_PWRGD : +3.40V
-IMVP_CKEN# : goes from +0V up to +2.18V (sometimes +1.8V, sometimes +1.4V) and down to +0V-- It goes up to +2.18V and should be so (high) I think when lap is on !! Isn't it ?
-TTSEN : +5.73V
-PM_DPRSLPVR initiates at +0.03V up to +0.12V and down to +0.03V then lap shuts down. It's low and should be so, I think!! Isn't it?

Is any of the above signals incorrect ?

freeqwer написал(а):

When the shutdown of the laptop disappears, only the voltage on the CPU ?
What are the voltages on the Board are still working ?


When Lap is ON main existing voltages are :
+5.73V and +3.79V
+2.06V (RAM)
+1.02V instead of +0.9V
VCCP : +1.19V
+1.78V instead of +1.5VS  high ??

When lap shuts off : remain only +5.73V and +3.79V.

Many thanks for your support.

0

16

mohkamtun написал(а):

(supply of +2V directly to pin 38)

you can try

mohkamtun написал(а):

TTSEN : +5.73V

:| 
TTSEN  connected to    +V5A . Where there voltage +5.73V  ?

TTSNS -  Thermal Throttling Sense and Crowbar Disable Input. A resistor divider where the upper resistor is
connected to VCC, the lower resistor (NTC thermistor) is connected to GND, and the center point is
connected to this pin and acts as a temperature sensor half bridge. Connecting TTSNS to GND disables
the thermal throttling function and disables the crowbar, or overvoltage protection (OVP), feature of the chip.

Maybe try to delete this pin to the ground ?

mohkamtun написал(а):

-VCORE_EN : +3.78V
-VR_PWRGD : +3.40V

Strange voltage .

mohkamtun написал(а):

-IMVP_CKEN# : goes from +0V up to +2.18V (sometimes +1.8V, sometimes +1.4V) and down to +0V-- It goes up to +2.18V and should be so (high) I think when lap is on !! Isn't it ?


I think this signal must be low level
I think the diagram incorrectly drawn .
This signal should be generated when the ADP3208 realized that all the voltage is normal, and gave the signal VR_PWRGD.
After that ADP3208 gives IMVP_CKEN# that goes to the clock generator .
But according to the scheme I don't see where it's coming from ( or where is) MVP_CKEN#

The idea is that IMVP_CKEN# shall be directed ICH8M and after receiving it , ICH8M sends a signal CLK_PWRGD to the clock generator RTM875T

After that ICH8M gives the signal H_PWRGD to the processor ,
who says that have all of the necessary voltage and a transition to the subsequent stage of initialization.

Further ICH8M gives the North PLT_RST# and removes the reset from the North

After that , the North bridge gives the signal H_CPURST# to the processor , removing the reset.

:dontknow:

mohkamtun написал(а):

+5.73V and +3.79V

o.O
What voltage ?
What voltage ? Standard voltage ?
Multimers you have is working ?
In any points of the circuit has a data voltage ?

The output U507 there PM_PWROK ?

0

17

freeqwer написал(а):

you can try


Supplied +2V directly to pin 38 got VCC_CORE = 0.3V. Raised supply to +3.2V got VCC_CORE : 0.4V almost 1 phase voltage.
 

freeqwer написал(а):

TTSEN  connected to    +V5A . Where there voltage +5.73V  ?
Maybe try to delete this pin to the ground ?


When connected TTSEN to gnd lap shuts off immediately.

freeqwer написал(а):

Strange voltage .
What voltage ?
What voltage ? Standard voltage ?
Multimers you have is working ?
In any points of the circuit has a data voltage ?


Y're right, voltages found with my digital multimeter are indeed strange! Measured voltages with my analog multimeter found correct voltages :

VCORE_EN : +3.3V
-VR_PWRGD : +2.99V
-IMVP_CKEN# : +1.92V. Will confirm tomorrow after checking a working Toshiba L300 whether this signal should be normally high or low.
-TTSEN : +5.04V
-PM_DPRSLPVR low (0.03V-0.12V)
So, my digital meter is giving wrong voltages ! i think that some of resistors might have changed value over time. need repair or replace.

freeqwer написал(а):

The output U507 there PM_PWROK ?


PM_PWROK = +3.3V

freeqwer написал(а):

This signal should be generated when the ADP3208 ...After that , the North bridge gives the signal H_CPURST# to the processor , removing the reset.


Very well explained IMVP_CKEN# and signals generated thereafter.

Thank you

0

18

Hi!
My feed Back : after checking ADP3208 IC in a working Toshiba L350 :

freeqwer написал(а):

I think this signal must be low level


CLKEN found=0V, low as you said to be.
But, in my failing toshiba [/b]it starts low and went quickly high level[/b], then lap shuts down.

Also, PM_DPRSLPVR should be high level. (=+1.17V in the working toshiba) but  found low level (0.03V-0.12V) in the failing Toshiba,  so I think that CPU is not in function mode, isn't it ?

Add Failing Toshiba tested with debug card, code stops at 78 -Bios is InsideH20, didn't find meaning of this code ?

Thank you

0

19

mohkamtun написал(а):

Add Failing Toshiba tested with debug card, code stops at 78 -Bios is InsideH20, didn't find meaning of this code ?

LINK

mohkamtun написал(а):

I think that CPU is not in function mode, isn't it ?

Thinking a lot   %-)   , and little help  8-)  ))
I think - Yes

Again, check all measurements were made serviceable multimeter :
+V3LA
+V5A
+V3S
+V5S
+V1.8A
+V0.9S
+V1.5S
+VCCP
+1.5 S
+VCC_CORE
+V1.25S
X1
X502
X500

When you try to run all of these voltages are available ?

To try to temporarily remove U1, U514, U531

Replace ADP3208 a known-good.

Replace the North bridge

To throw this laptop in the garbage  :D

0

20

freeqwer написал(а):

LINK

Thinking a lot      , and little help    ))
I think - Yes

:cool:

freeqwer написал(а):

Again, check all measurements were made serviceable multimeter :
+V3LA
+V5A
+V3S
+V5S
+V1.8A
+V0.9S
+V1.5S
+VCCP
+1.5 S
+VCC_CORE
+V1.25S
X1
X502
X500

When you try to run all of these voltages are available ?

To try to temporarily remove U1, U514, U531

Replace ADP3208 a known-good.

Replace the North bridge

To throw this laptop in the garbage


I think it's better for me to take a great breath before resuming the repair of this crazy Toshiba lap !!!

Will move on other repairs, and give feed back on Toshiba in some days.
If problem is not solved, thereafter,

freeqwer написал(а):

To throw this laptop in the garbage

:cool:

I 'll agree then, that'll be the best way to solve definitely the issue!!  :yep:

O I noticed with great surprise the enlargement of Tunisian flag in the this Topic and was deeply impressed  by your kind attention coming on the right moment !

It made me feel I'm dealing rather with a cool friend than an Administrator and Owner of the forum.

So, thank you very much!

Отредактировано mohkamtun (21.03.2015 23:39:32)

0

21

Toshiba was returned to customer without repair on his request. I advised  him to throw it! :D

This topic can be closed.

Thank you for your good support.

0


Вы здесь » Ремонт ноутбука своими руками. » Asus, Toshiba » Toshiba L350-156 shuts down after 2 seconds display.